Linux based routers and Console Connect

  • 26 December 2022
  • 0 replies

Userlevel 1
Badge +1

I ran into an issue when setting my up Linux based router (Danos Vyatta Edition) with Console Connect. Traffic on my Internet on Demand circuit mostly worked but a few applications wouldn’t connect or connected very slowly.


I took two packet captures, one with IoD enabled and one without IoD enabled so I could compare the two. The one without IoD enabled showed the application filling up the packet size allowed and flowing through the router just fine. The capture with IoD enabled also showed full packets but the connections would stall. 


Turns out on Linux based routers, you need to set the MTU of the physical port to 1522 and the VLAN to 1500. Both default to 1500 from a basic install. The VLAN header was pushing the packet over the MTU limit and causing them to drop instead of renegotiate.


The Console Connect L2 documentation briefly describes the MTU setting.Port Specifications

0 replies

Be the first to reply!